Deviant Login Shop  Join deviantART for FREE Take the Tour
×



Details

Submitted on
September 13, 2013
File Size
5.4 MB
Link
Thumb
Embed

Stats

Views
20,885 (27 today)
Favourites
181 (who?)
Comments
110
Downloads
3,227 (3 today)
×
Lux by Markkoenig Lux by Markkoenig
Minimalistic skin for foobar2000 v.1.2.9+ and Windows 7! (UI_Hacks not working on W8?)


To install the skin on foobar 1.3, just DON'T OVERWRITE ANY STOCK COMPONENT OR .CFG FILE. If you do, you'll replace up-to-date components with outdated ones, and foobar won't start, saying some components have been damaged.


:) Thanks a LOT for the DailyDev! I'm really pleased you guys like this skin. :) 10,000 views! Yeah!

First-of-all , I give thanks and credit to slowboyfast for his Placebo Monolithic v3, to Br3tt for his CoverFlow v.1.4, to thanhdat1710 for his WSH Library search v1 and to MacStew for his rating WSH panel mod.

To install
Unzip everything to a portable installation folder, overwrite everything and run.

To install in a normally installed foobar
  1. Use a fresh installation to avoid compatibility issues.
  2. Once the skin is installed, remember to untick the "Safe Mode" for WSH : Prefs/Tools/WSH.
  3. Paste "skins", "components" and "configuration" folders into the foobar2000 directory and overwrite everything.
  4. Go to [USER]AppDataRoaming and create a "foobar2000" folder, then copy "skins" and "configuration" into OR launch foobar, it will create the AppData folder, and then copy the folders, to make sure the configuration files won't be overwritten.
  5. Install Shpeck and the fonts.
  6. Then start.


Then
Pretty much everything is written on the picture.
  1. The use of UI_Hacks causes some mess with GDI text rendering. Over a light background, text strings in the Explorer and CoverFlow tabs will appear non-antialiased, whereas they will appear antialiased over dark background. I eluded the problem on the Lyrics and Bio tabs by deactivating the antialiasing, but it would be great if someone had an efficient trick.
  2. If you want to extend the aero blur effect to the entire window (that was my first purpose), go to Prefs/Main Window and select "sheet of glass" instead of "glass frame".
  3. To move the window, maintain the mouse scroll button down. You can change it in Prefs/Main Window.
  4. If you resize your foobar window, you may want to allow more or less space to the Now Playing string : go to Prefs/ColumnsUI/Layout/[first Panel Stack Splitter]/[COMMANDS]/Configure/Script and it's somewhere in the last lines. Default value is 25.
  5. Click anywhere on the Now Playling string to activate the playing track in the ELplaylist.
  6. The weblinks panel is modified from marc20003's one on a skin called "Gas" (I couldn't find it a week later) ; I left the Spotify search command, but as I don't have Spotify, I couldn't check on it. A feedback would be very appreciated.
  7. Don't forget to install the included fonts.
  8. In order to use Shpeck, you'll have to install Winamp (only the .exe is needed, you can delete all the other files) and paste the "Plugins" folder included in this archive in the Winamp directory. If the visualization is not automatically started, go to Prefs/Visualizations/Shpeck, point the .exe, select the Classic Spectrum Analyzer in the list and hit "Start".
  9. If you'd like to modify the buttons, the (messy) .psd files are here. The default color values are pure white, alpha 20%/80% ; black 30-30-30, alpha 20%/80%.


droot1986 suggested a background for the score board (screenshot) ; to do so, put your image into the images folder and add an $imageabs function in Prefs/ColumnsUI/[first Panel Stack Splitter]/Configure/COMMANDS/Configure/Script.

Minor bugs
  1. The first time you'll start foobar, the rating panel will crash. I don't have any clue why, it never happened with the installation in which I built the skin. Don't worry, start playing a track, reload the script (right click/Configure/Ok) and it will work as a charm.
  2. The weblinks probably won't show up at first start either, but again play a track and they'll appear. I must have missed something somewhere, sorry for that. Might not happen on a normal installation.


N.B. : this skin lies on the UI_Hacks component, which is frequently flagged as trojan or virus (cf. its name).

One of the wallpapers is here and I lost the other one.
Add a Comment:
 

Daily Deviation

Given 2013-09-17
Lux by ~Markkoenig ( Featured by fediaFedia )
:iconnullio0:
Hi, I tried installing your skin but when I started foobar, I got an error saying "Internal error - one or more of the installed components have been damaged". :(
Reply
:iconmarkkoenig:
Markkoenig Jan 12, 2014  Hobbyist Interface Designer
That must be a compatibility error. You have to overwrite the components you already have. That's why I recommed installing it on a fresh new installation. I just saw that f2k 1.3 final hed been released, but if you install 1.3 and then install the skin and save the .fcl file, there shouldn't be any problem (worked with 1.3 beta 5).
Reply
:iconnullio0:
I tried using a fresh uninstall as well (uninstalled everything then reinstalled), but it still gives me that error. Also, where or how do I save the fcl file? Thanks.
Reply
:iconmarkkoenig:
Markkoenig Jan 18, 2014  Hobbyist Interface Designer
To save the .fcl file, Prefs/Columns UI/Main. Which version of foobar do you use?
Reply
:iconnullio0:
sorry, i meant fresh install
Reply
:iconnullio0:
So I tried troubleshooting and replaced the components one by one and found out that my foobar wouldn't launch after I replaced the foo_input_std.dll. I then proceeded to replacing everything else and got This when I opened up foobar.
Reply
:iconmarkkoenig:
Markkoenig Jan 21, 2014  Hobbyist Interface Designer
Well I don't know much about that component, I checked my own foobar, i'm using version 1.0... And I just installed my skin to a fresh foobar v1.3 final, there is no problem at all :/ 
Reply
:iconmarkkoenig:
Markkoenig Jan 21, 2014  Hobbyist Interface Designer
I'm sooo sorry, my mistake! I thought we were talking about my last one, Nightshift! It works perfectly with 1.3, you just need to install everything EXCEPT ANY STOCK v1.3 component and .cfg file (in folder 'configuration'). If you do so, you will replace up-to-date components with outdated ones, obviously. I'm sorry I have kept you waiting for such a simple solution, my apologies.

Btw, the rating panel will still crashed at the first start, just right click/configure/Apply without touching anything, done.
Reply
:iconnullio0:
Thanks for the reply, I seem to have gotten most of the skin to work. But the bottom bar where the web searches are still isn't working. :(
See picture
Reply
(5 Replies)
:iconusernamey:
I had the same problem too. It seems that this isnt compatible with 1.3 :c

Im using this with v1.2.9 from oldapps.com and its working perfectly :)

This is a great skin!
Reply
Add a Comment: